arkmanager - mehrere Instanzen in einem Cluster - Client crash

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • arkmanager - mehrere Instanzen in einem Cluster - Client crash

    Hallo zusammen,

    Ich habe vor einigen Tagen mit ark-server-tools einen ARK-Server auf meinem Debian 10 Server aufgesetzt.

    Solange ich nur eine Instanz mit arkmanager laufen lasse, funktioniert alles problemlos. Sobald ich eine zweite starte, ist es nicht mehr möglich eine von beiden zu joinen, der Client stürzt ab. Wenn man es nach dem ersten Crash nochmals versucht, stürzt das Spiel schon im Server-Browser ab, bevor man überhaupt auf "Beitreten" klickt. Getestet mit zwei Clients, die beide im selben Netzwerk stehen wie der Server.

    Aus Server-Sicht starten beide Instanzen sauber, auch bei arkservers.net/ werden sie aufgelistet. Keine Fehler in arkserver.log oder arkmanager.log. Ports sind getrennt und in iptables und im Router freigegeben. Wenn ich nur eine Instanz starte, diese dann joine und anschließend die zweite starte, funktioniert es so lange bis ich disconnecte und wieder joinen möchte. Auch dann stürzt der Client wieder ab.

    Ich habe bereits alles neu aufgesetzt (Benutzer neu angelegt, steamcmd, ark-server-tools und ark neu installiert) und auch mal zwei Instanzen mit vollständig getrennten ARK-Ordnern getestet. Alles führt zum selben Ergebnis.

    Meine configs:
    /etc/arkmanager/arkmanager.cfg: pastebin.com/aBmZzg8L
    /etc/arkmanager/instances/TheIsland.cfg: pastebin.com/ZB0LsCuK
    /etc/arkmanager/instances/ScorchedEarth.cfg: pastebin.com/BuWSy1F7

    Der Fehler am Client: imgur.com/a/bRJljsZ

    Da ich aktuell keine Idee mehr habe wo es hängt, hoffe ich hier auf Hilfe.

    Danke.

    The post was edited 2 times, last by chr1s1211 ().

  • chr1s1211 wrote:

    /etc/arkmanager/instances/
    Der Pfad ist schon mal Falsch,
    der Arkmanager soll alleine in /etc/arkmanager laufen


    Das Spiel selber entweder nach
    /home
    /opt/.....
    /usr/local/....
    Installieren, ich helfe dir gerne weiter, da ich der jenige bin der das tut hier machte vor Jahren :D, als das ding noch im Screen lief :D

    The post was edited 1 time, last by Sam| ().

  • Die Ordner instances hat ark-server-tools selbstständig in /etc/arkmanager/ angelegt. Das ist nicht korrekt so?

    So wie ich das verstanden habe sind die Instanz-übergreifenden Variablen in /etc/arkmanager/arkmanager.cfg hinterlegt, wobei die Instanz-spezifischen Variablen in den jeweiligen Instanz-Configs in /etc/arkmanager/instances/ festgelegt werden?

    Das Spiel liegt unter /home/steam/ARK/. Für mich sieht es erstmal nicht nach einem Zugriffsproblem aus, da ja alles normal funktioniert solange nur eine Instanz läuft. Scheinbar kommen die sich irgendwie in die Quere sobald eine zweite dazu kommt.

    Vielen Dank schon mal für die schnelle Hilfe. :)

    //edit: Oh, hab zu lange gebraucht zum Antworten. :D
    Images
    • ark.jpg

      83.93 kB, 560×416, viewed 4 times
  • meine ark1.cfg

    # config environment
    arkserverroot="/opt/steam/arkcluster1" # path of your ARK server files (default ~/ARK)

    # ARK server options - use ark_<optionname>=<value>
    # comment out these values if you want to define them
    # inside your GameUserSettings.ini file
    serverMap="Valguero_P" # server map (default TheIsland)
    #serverMapModId="469987622" # Uncomment this to specify the Map Mod Id (<fileid> in ?id=<fileid>)
    #ark_TotalConversionMod="496735411" # Uncomment this to specify a total-conversion mod
    ark_RCONEnabled="True" # Enable RCON Protocol
    ark_RCONPort="32330" # RCON Port
    ark_SessionName="[DE/PVE]Die Zeitscheißer(Hx2,Tx2)+Cluster" # if your session name needs special characters please use the .ini instead
    ark_Port="7778" # ARK server port (default 7778)
    ark_QueryPort="27016"
    arkbackupdir="/opt/steam/ark-backups/Valguero" # ARK query port (default 27015)
    ark_ServerPassword="" # ARK server password, empty: no password required to login
    ark_ServerAdminPassword=".............." # ARK server admin password, KEEP IT SAFE!
    ark_MaxPlayers="15"
    ark_GameModIds="731604991,1786522940,538827119,791674340,741203089,1184731864,1577307175" # Uncomment to specify additional mods by Mod Id separated by commas
    #ark_AltSaveDirectoryName="SotF" # Uncomment to specify a different save directory name

    # ARK server flags - use arkflag_<optionname>=true
    #arkflag_OnlyAdminRejoinAsSpectator=true # Uncomment to only allow admins to rejoin as spectator
    #arkflag_DisableDeathSpectator=true # Uncomment to disable players from becoming spectators when they die

    # ARK server options - i.e. for -optname=val, use arkopt_optname=val
    #arkopt_StructureDestructionTag=DestroySwampSnowStructures

    #arkPreStart="/etc/arkmanager/instances/instance.start"

    # ark cluster settings <<<< Das ist Wichtig und muss in jeder Instanc.cfg stehen !!!
    arkflag_NoTransferFromFiltering=""
    arkopt_clusterid=cluster001
    arkopt_ClusterDirOverride=/opt/steam


    #Mod liste
    #Struktur Plus 731604991 Aktiv
    #Big Storage 791674340 Aktiv
    #Omicular 538827119 Aktiv
    #ecox RP Decor 741203089 Aktiv
    #Eco Trees 670764308 Aktiv
    #StackMeMore (v1.41) 1184731864 Aktiv
    #BA Gacha Crystal Collector 1577307175
    #Valguero Dino und Map Extension Mod ID: 1786522940
  • Sam| wrote:

    meine ark1.cfg

    # config environment
    arkserverroot="/opt/steam/arkcluster1" # path of your ARK server files (default ~/ARK)

    # ARK server options - use ark_<optionname>=<value>
    # comment out these values if you want to define them
    # inside your GameUserSettings.ini file
    serverMap="Valguero_P" # server map (default TheIsland)
    #serverMapModId="469987622" # Uncomment this to specify the Map Mod Id (<fileid> in ?id=<fileid>)
    #ark_TotalConversionMod="496735411" # Uncomment this to specify a total-conversion mod
    ark_RCONEnabled="True" # Enable RCON Protocol
    ark_RCONPort="32330" # RCON Port
    ark_SessionName="[DE/PVE]Die Zeitscheißer(Hx2,Tx2)+Cluster" # if your session name needs special characters please use the .ini instead
    ark_Port="7778" # ARK server port (default 7778)
    ark_QueryPort="27016"
    arkbackupdir="/opt/steam/ark-backups/Valguero" # ARK query port (default 27015)
    ark_ServerPassword="" # ARK server password, empty: no password required to login
    ark_ServerAdminPassword=".............." # ARK server admin password, KEEP IT SAFE!
    ark_MaxPlayers="15"
    ark_GameModIds="731604991,1786522940,538827119,791674340,741203089,1184731864,1577307175" # Uncomment to specify additional mods by Mod Id separated by commas
    #ark_AltSaveDirectoryName="SotF" # Uncomment to specify a different save directory name

    # ARK server flags - use arkflag_<optionname>=true
    #arkflag_OnlyAdminRejoinAsSpectator=true # Uncomment to only allow admins to rejoin as spectator
    #arkflag_DisableDeathSpectator=true # Uncomment to disable players from becoming spectators when they die

    # ARK server options - i.e. for -optname=val, use arkopt_optname=val
    #arkopt_StructureDestructionTag=DestroySwampSnowStructures

    #arkPreStart="/etc/arkmanager/instances/instance.start"

    # ark cluster settings <<<< Das ist Wichtig und muss in jeder Instanc.cfg stehen !!!
    arkflag_NoTransferFromFiltering=""
    arkopt_clusterid=cluster001
    arkopt_ClusterDirOverride=/opt/steam


    #Mod liste
    #Struktur Plus 731604991 Aktiv
    #Big Storage 791674340 Aktiv
    #Omicular 538827119 Aktiv
    #ecox RP Decor 741203089 Aktiv
    #Eco Trees 670764308 Aktiv
    #StackMeMore (v1.41) 1184731864 Aktiv
    #BA Gacha Crystal Collector 1577307175
    #Valguero Dino und Map Extension Mod ID: 1786522940
    Das steht bei mir auch in jeder Instanz-Config drin. Wobei es theoretisch ja auch reichen müsste wenn man es in die arkmanager.cfg rein schreibt, da diese options ja von jeder Instanz übernommen werden?
  • Sam| wrote:

    chr1s1211 wrote:

    /home/steam/ARK/
    und in den ordern /home/steam muss noch der Ordner clustersKannst mich auch gerne ma bei uns im ts besuchen kommen
    Der Cluster-Ordner ist bei mir in "/etc/home/steam/ARK/Shared", steht auch so in jeder config drin: "arkopt_ClusterDirOverride="ShooterGame/Shared"".
    Ist das so nicht korrekt?

    Komme später gerne in den TS. Jetzt gerade ist es mir leider nicht möglich.
  • chr1s1211 wrote:

    Der Cluster-Ordner ist bei mir in "/etc/home/steam/ARK/Shared", steht auch so in jeder config drin: "arkopt_ClusterDirOverride="ShooterGame/Shared"".

    chr1s1211 wrote:

    /etc/home/steam/ARK/Shared
    na wie du die Pfade machst bleibt dir überlassen, aber dann stimmt arkopt_ClusterDirOverride="ShooterGame/Shared" nicht

    The post was edited 1 time, last by Sam| ().

  • Ja, da habe ich den falschen Pfad drin. Danke!

    Ich habe das korrigiert und die configs dazu ein wenig aufgeräumt.

    Alles was sich auf alle Instanzen bezieht in die arkmanager.cfg und alles was spezifisch ist in die jeweilige Instanz-Config. Sieht dann jetzt folgendermaßen aus:

    /etc/arkmanager/arkmanager.cfg
    /etc/arkmanager/instances/TheIsland.cfg
    /etc/arkmanager/instances/ScorchedEarth.cfg

    Ob es an dem falschen Pfad gelegen hat kann ich leider erst später testen. Beide Instanzen starten jedenfalls korrekt, aber das war ja auch schon vorher so.

    //edit: "ark_MaxPlayers="10"" wird scheinbar ignoriert wenn es in der arkmanager.cfg steht, daher habe ich es wieder in beide Instanz-Configs eingetragen. Ist das bei anderen Settings möglicherweise genau so?

    The post was edited 2 times, last by chr1s1211 ().